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What will we do today?



!

!

• Introduction to unit 

• Learn about how to share resources 

• Discuss and Install Game Salad 

What will we do today?



What is Game Salad?







What makes a good game?
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What makes a quality game?

• Aesthetics and Scalability

• Usability

• Performance

• Creative and Marketable

• Framework



What’s your favorite 
game and why?
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because it looks really cool!



What’s your favorite 
game and why?

• Supermario is my favorite game 
because it looks really cool!

• ____ is my favorite game because it is 
fun to play.   



What’s your favorite 
game and why?

• Supermario is my favorite game 
because it looks really cool!

• ____ is my favorite game because it is 
fun to play.   

• ____ is my favorite game because ____.
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What will we do today?



!

• Attendance 

• Bingo! 

• Download resources 

• Review Assignment 

• Learn how to Animate

What will we do today?



Let’s Play Bingo!



How to Play?
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How to Play?!

• Find people in the class that can do 
the things listed on the sheet. Each 
person you find gets you one box.



How to Play?

!

• Go around ask people the questions on 
the board, they can do it, have them 
write their name in your Bingo 
scorecard.



How to Play?
• The goal is to get three boxes in a row 

• Find people in the class that can do 
the things listed on the sheet. Each 
person you find gets you one box. 

• Go around ask people the questions on 
the board, they can do it, have them 
write their name in your Bingo 
scorecard.



Let’s review

• Who can do the things listed? 

• Let’s do them 

• Any questions?



Download resources
• Go to Skynet 

• Copy the DESIGN folder to your 
desktop 

• If you need help ask a friend that you 
found in Bingo or someone else who 
can help



Assignment
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Design
The Marshmallow Challenge
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What will we do today?

• Attendance

• Review

• Talk about Assignment: Update

• Learn

• Work on Assignment
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Assignment

• When is it due?

• This Friday

• How many tutorials?

• Minimum is 3

• Where to put the files?

• ManageBac
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Mac vs PC
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What did we learn today?
• Import graphics and sounds

• Give key commands to actors

• Program actors to move

• Change scenes

• New vocabulary
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Approaches to Learning

• Inquirer

• Thinker



Approaches to Learning

• Inquirer

• Thinker

• Communicator
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What will we do today?



What will we do today?

• Attendance / Review Vocabulary

• FAQ

• Learn: Score, Spawn, Destroy!

• Work on Projects
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Every person must use a vocab word from last week
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Review Vocabulary

• Project 

• Home 

• Scenes 

• Actors 

• Tables 

• Preview 

•프로젝트  

•홈  

•장면  

•배우  

•테이블  

•미리보기 

•项⽬目  
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•演员  

•表  

•预览
Every person must use a vocab word from last week
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FAQ
• How to change scenes?

• Use the change scene behavior

• How to change score?

• Use change attributes

• What to do if you don’t know what to do?

• Ask friend, watch tutorial, write question 
on the FAQ board.  



Learn



Score



Spawn



Spawn

• This text spawns when I push a
button and then will be destroyed
when I push the button again



Spawn



Destroy
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New Vocabulary

• Behaviors 

• Timer 

• Spawn 

• Destroy 

• Change 

• Attribute 

•동작  

•타이머  

• ???  

•파괴  

•변경  

•속성 

•⾏行为  

•定时器  

• ???  

•销毁  

•更改  

•属性



Assignment

• Watch the video tutorials 

• Make the games



MYP Design

Unit 1: Digital Game Design

MYP Design

Unit 1: Digital Game Design



MYP Design
Unit 1: Digital Game Design



What will we do today?



What will we do today?

• Attendance / Review Vocabulary

• Discuss Assignment

• Share Assignments

• Finish Assignments



FAQ
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FAQ
• What to do if I don’t know what to do?

• Ask friend, watch tutorial, read the manual, 
write question on the FAQ board.

• What to do if I am going to be late or need 
extra time for any reason?

• Discuss or send an email to the teacher 
explaining your situation and plan.



Every person must use a vocab word from last week
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• Project 

• Home 

• Scenes 

• Actors 

• Tables 

• Preview 

•프로젝트  

•홈  

•장면  

•배우  

•테이블  

•미리보기 

•项⽬目  

•⾸首页  

•场景  

•演员  

•表  

•预览
Every person must use a vocab word from last week

Vocabulary Review



What was the 
Assignment?
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Assignment?

• Watch the video tutorials



What was the 
Assignment?

• Watch the video tutorials

• Make the games
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How many games?

• 7 Grade = 1 or more



How many games?

• 7 Grade = 1 or more

• 8 Grade = 2 or more
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Where does the 
assignment go?

• Upload to ManageBac



Upload to ManageBac



When was it due?

• Finish before lunch tomorrow  

• Not finished = homework detention 
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FAQ
• What to do if I don’t know what to do?

• Ask friend, watch tutorial, read the manual, 
write question on the FAQ board.

• What to do if I am going to be late or need 
extra time for any reason?

• Discuss or send an email to the teacher 
explaining your situation and plan.



Let’s play a game!
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Vocabulary Review

• Behaviors 

• Timer 

• Spawn 

• Destroy 

• Change 

• Attribute 

•동작  

•타이머  

• ???  

•파괴  

•변경  

•속성 

•⾏行为  

•定时器  

• ???  

•销毁  

•更改  

•属性



Next time

• Play and compare games!



Computer Basics

• Charge 

• Save 

• Screenshot 

• Import
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What will we do today?



What will we do today?

• Attendance

• Grade Updates

• New Project: Play Games!

• Work on Project

• Questions



Grade Updates



Grade Updates

• You will receive updates next week

• What does each score mean?

• They can change for better or worse

• How can I improve?



Final Grade



How do I get criteria 
grades?



Preparedness



Preparedness



Activity



Activity



Cooperation



Cooperation
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New Assignment



• Where can I find out about all my 
assignment?

New Assignment



• Where can I find out about all my 
assignment?

• ManageBac

New Assignment



• Where can I find out about all my 
assignment?

• ManageBac

• What to do if I am going to be late or need 
extra help or time for any reason?

New Assignment



• Where can I find out about all my 
assignment?

• ManageBac

• What to do if I am going to be late or need 
extra help or time for any reason?

• Discuss or send an email to the teacher 
explaining your situation and plan.

New Assignment
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New Assignment



• What do I have to do?

New Assignment



• What do I have to do?

• Play and analyze games.

New Assignment



• What do I have to do?

• Play and analyze games.

• Just play games?

New Assignment



• What do I have to do?

• Play and analyze games.

• Just play games?

• No! You also have to take screenshots and 
analyze the differences in aesthetics, 
usability, performance, and marketability.

New Assignment





Computer Essentials



Computer Essentials
How to do: Screenshots



Screenshot Basics



Screenshot Basics

• What is a screenshot? 



Screenshot Basics

• What is a screenshot? 

• How to take screenshots



What is a screenshot?



What is a screenshot?

• It’s a picture of what is on your 
computer screen



Two types of screenshots



• A picture of your whole screen
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• A picture of your whole screen

• A picture of part of the screen

Two types of screenshots

Shift + Command + 3

Shift + Command + 4



• A picture of your whole screen

• A picture of part of the screen

Two types of screenshots

Shift + Command + 3

Shift + Command + 4



Windows



• Window 7

Windows



• Window 7

Windows

• Windows XP
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What makes a good game?

Graphics



What makes a good game?

Graphics Gameplay



What makes a good game?

Graphics Gameplay Sounds
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What makes a quality game?

• Aesthetics and Scalability The way it looks

• Usability The way it plays

• Performance It works well

• Creative and Marketable



What makes a quality game?

• Aesthetics and Scalability The way it looks

• Usability The way it plays

• Performance It works well

• Creative and Marketable It is interesting 



Example Assignment
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What will we do today?



What will we do today?

• Attendance

• New: Task 4

• Learn and Discuss: Design Brief

• Do worksheet

• Work on projects

• Questions and 1-on-1



Attendance



Attendance
• What would you like to design? 

• I would like to design a _________ 

• Not paying attention?  

• Option 1: Write a sentence for 5 
vocabulary words 

• Option 2: Explain which IB learner 
profile attribute you feel you can 
improve



Task 4



Task 4

• Write a Design Brief

• https://qais.managebac.com/classes/
10269061/events/12086449

https://qais.managebac.com/classes/10269061/events/12086449


What is a Design Brief?
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What is a Design Brief?

• It is a brief overview of: 

• What you want to design

• Why you want to design

• Who you want to design it for



Worksheet



Worksheet
• Fill out this worksheet and present 

your ideas to the class 

• Once you are finished with the 
worksheet you can begin working on 
your Design Brief 

• You can work in teams BUT everyone 
must turn in their own assignment to 
ManageBac and have every members 
name on assignment
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What will we do today?



What will we do today?

• Attendance

• Review: Final Steps of the Project

• Learn: Gantt Chart

• Questions

• Work on projects



Instructions



Instructions

• Open ManageBac

• Read the TWO new tasks

• Task 6

• Task 7



Instructions



Instructions

• Discuss task 6 with your group and
answer these questions:

• What is the assignment?

• When is it due?

• What is a Gantt Chart?



Instructions



Instructions

• Discuss task 7 with your group and
answer these questions:

• What is the assignment?

• When is it due?

• What do I need to upload?



Complete Task 6



Complete Task 6

• Read instructions

• Download example AND template

• Look at example

• Fill in template

• Rename file and upload to Managebac
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What will we do today?

• Attendance: Answer the questions

• Review

• Learn: Make music with Garageband

• Questions

• Work on projects



Attendance
1. Write your name 
2. Discuss the questions 
3. Write your answers 
4. Turn in to Mr. JD



System
Systems are sets of interacting or interdependent 

components. Systems provide structure and order in 
human, natural and built environments. Systems 

can be static or dynamic, simple or complex. 



What are we going to do?
• 1. Make a song  

• 2. Upload to Game 

• 3. Play sound in game

1st to Finish Complete Task
2 Points 1 Points

Help Complete
1 Points



1. Make a song



1. Make a song

• Open Garageband

• File > New Project

• View > Show Apple Loops

• Drag the loop into the track

• Share > Export song to disk
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1. Make a song

• Open Garageband

• File > New Project

• View > Show Apple Loops

• Drag the loop into the track

• Share > Export song to disk



Upload Song to Game



Upload Song to Game
• Open GameSalad 

• File > New 

• Scenes > Initial Scene 

• Sounds > Push the plus sign “+”  

• Select song and add as music 

• Create new actor and double click it 

• Add behavior > Play Music > loop
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Upload Song to Game
• Open GameSalad 

• File > New 

• Scenes > Initial Scene 

• Sounds > Push the plus sign “+”  

• Select song and add as music 

• Create new actor and double click it 

• Add behavior > Play Music > loop
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What will we do today?



What will we do today?

• Attendance: Share games with class

• FAQ: Frequently Asked Questions

• Review: How to solve problems?

• Work on projects

• Meeting with teams/individuals



Attendance



Attendance

• Open computers and load game info 

• Prepare to use Apple TV/big screen to:  

• Briefly share games with whole 
class (1-2 minutes each group) 

• Include brief overview of game



FAQ
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FAQ
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task 7?
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• How many things do I need to upload for 
task 7?

• You need to upload two things to 
Managebac.

• Your final game

• Game creation process document

• When is it due?

• November 12th, 8 a.m.

FAQ



FAQ
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FAQ
• What to do if I don’t know what to do?

• Ask friend, watch tutorials, read the 
manual, write question on the FAQ board.
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FAQ
• What to do if I don’t know what to do?

• Ask friend, watch tutorials, read the 
manual, write question on the FAQ board.

• What to do if I am going to be late or need 
extra time for any reason?

• Discuss or send an email to the teacher 
explaining your situation and plan.



Tips for solving problems



Tips for solving problems

• Use reliable sources

• Use important key words

• Specific vs. General

• Use logic /逻辑 /논리



What to do?



What to do?

• Work on projects

• Meeting with teams/individuals


